loading...
Cover image for Vuln Cost Plugin for Visual Studio Code
Snyk

Vuln Cost Plugin for Visual Studio Code

brianverm profile image 🧑🏼‍💻 Brian Vermeer ・1 min read

Visual Studio Code is probably the most widely-used code editor for JavaScript developers. As 80 or maybe even 90 percent of the code developed is heavily dependent on open source packages, developers need to know what these packages do.

Do you, for instance, know for all the packages you import if they contain known security vulnerabilities? I created this free, open source, Vuln Cost extension for VS Code can help you with this. Vuln Cost enables you to see existing vulnerabilities and their severity in the open source packages you import, as you code.

Feel free to reach out, and let us know what you think.

Discussion

pic
Editor guide
Collapse
piprees profile image
Pip

This is a really great extension! Just installed it alongside Error Lens, and it works like a charm!

Collapse
shar1z profile image
Sharone Zitzman

That's awesome! Thanks for letting us know - always happy to see folks using our tools. Feel free to ask any questions and share ideas!